Welcome to the usis LocalDB Class Library

The usis LocalDB Class Library provides a .NET wrapper for the SQL Server Express LocalDB Instance APIs.

Namespace

All types of the class library are contained in the usis.Data.LocalDb namespace.

NuGet

usis.Data.LocalDb is available as NuGet Package: https://www.nuget.org/packages/usis.Data.LocalDb/

Documentation

This documentation is available online at https://help.usis-software.com/LocalDB/ or can be download as Compiled HTML Help (.CHM) file.

See Also

Other Resources

Version History

Copyright © 2018 usis GmbH

Send comments on this topic to support@usis-software.com


Version History

The topics in this section describe the various changes made to the usis LocalDB Class Library over the life of the project.

Version History

Select a version below to see a description of its changes.

  • Version 1.0.0.0

See Also

Other Resources

Welcome to the usis LocalDB Class Library


Version 1.0.0.0

Version 1.0 was released on June 05, 2018.

Changes in This Release

  • This is the initial release.

See Also

Other Resources

Version History


usis.Data.LocalDb Namespace

The usis.Data.LocalDb namespace contains the types that allows you to use the SQL Server Express LocalDB instance API from a .NET Framework application.
Classes
 | Class | Description
Public class | Extensions | Provides extension methods for the Manager class.
Public class | InstanceInfo | Provides information about a SQL Server Express LocalDB instance.
Public class | LocalDbException | Throws an exception for a SQL Server Express LocalDB error.
Public class | Manager | Provides methods to manage LocalDB instances.
Public class | VersionInfo | Provides information about a SQL Server Express LocalDB version.
Enumerations
 | Enumeration | Description
Public enumeration | StopInstanceOptions | Describes to options that spectify the way to stop an instance.


Extensions Class

Provides extension methods for the Manager class.
Inheritance Hierarchy
SystemObject
usis.Data.LocalDbExtensions

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class Extensions
<ExtensionAttribute>
Public NotInheritable Class Extensions
[ExtensionAttribute]
public ref class Extensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type Extensions =  class end

The Extensions type exposes the following members.

Methods
Name | Description
CreateInstance | Creates a new SQL Server Express LocalDB instance with the highest istalled version.
EnumerateInstances | Gets the informations about both named and default LocalDB instances on the user’s workstation.
EnumerateVersions | Returns all SQL Server Express LocalDB versions available on the computer.
StopInstance(Manager, String) | Stops the specified SQL Server Express LocalDB instance from running.
StopInstance(Manager, String, Int32) | Stops the specified SQL Server Express LocalDB instance from running.
Top
See Also

Reference

usis.Data.LocalDb Namespace


Extensions Methods

The Extensions type exposes the following members.

Methods
Name | Description
CreateInstance | Creates a new SQL Server Express LocalDB instance with the highest istalled version.
EnumerateInstances | Gets the informations about both named and default LocalDB instances on the user’s workstation.
EnumerateVersions | Returns all SQL Server Express LocalDB versions available on the computer.
StopInstance(Manager, String) | Stops the specified SQL Server Express LocalDB instance from running.
StopInstance(Manager, String, Int32) | Stops the specified SQL Server Express LocalDB instance from running.
Top
See Also

Reference

Extensions Class


Extensions.CreateInstance Method

usis LocalDB Class Library

ExtensionsCreateInstance Method

Creates a new SQL Server Express LocalDB instance with the highest istalled version.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void CreateInstance(
    this Manager manager,
    string instanceName
)
<ExtensionAttribute>
Public Shared Sub CreateInstance (
    manager As Manager,
    instanceName As String
)
public:
[ExtensionAttribute]
static void CreateInstance(
    Manager^ manager,
    String^ instanceName
)
[<ExtensionAttribute>]
static member CreateInstance :
        manager : Manager *
        instanceName : string -> unit

Parameters

manager
Type: usis.Data.LocalDbManager
The LocalDB manager object.
instanceName
Type: SystemString
The name for the LocalDB instance to create.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Manager. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentNullException | manager is a null reference.
See Also

Reference

Extensions Class


Extensions.EnumerateInstances Method

ExtensionsEnumerateInstances Method

Gets the informations about both named and default LocalDB instances on the user’s workstation.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<InstanceInfo> EnumerateInstances(
    this Manager manager
)
<ExtensionAttribute>
Public Shared Function EnumerateInstances (
    manager As Manager
) As IEnumerable(Of InstanceInfo)
public:
[ExtensionAttribute]
static IEnumerable<InstanceInfo^>^ EnumerateInstances(
    Manager^ manager
)
[<ExtensionAttribute>]
static member EnumerateInstances :
        manager : Manager -> IEnumerable<InstanceInfo>

Parameters

manager
Type: usis.Data.LocalDbManager
The LocalDB manager object.

Return Value

Type: IEnumerable InstanceInfo
An enumerator to iterate through all instance informations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Manager. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Extensions Class


Extensions.EnumerateVersions Method

ExtensionsEnumerateVersions Method

Returns all SQL Server Express LocalDB versions available on the computer.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<VersionInfo> EnumerateVersions(
    this Manager manager
)
<ExtensionAttribute>
Public Shared Function EnumerateVersions (
    manager As Manager
) As IEnumerable(Of VersionInfo)
public:
[ExtensionAttribute]
static IEnumerable<VersionInfo^>^ EnumerateVersions(
    Manager^ manager
)
[<ExtensionAttribute>]
static member EnumerateVersions :
        manager : Manager -> IEnumerable<VersionInfo>

Parameters

manager
Type: usis.Data.LocalDbManager
The LocalDB manager object.

Return Value

Type: IEnumerable VersionInfo
An enumerator to iterate through all version informations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Manager. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Extensions Class


Extensions.StopInstance Method

ExtensionsStopInstance Method

Overload List
Name | Description
StopInstance(Manager, String) | Stops the specified SQL Server Express LocalDB instance from running.
StopInstance(Manager, String, Int32) | Stops the specified SQL Server Express LocalDB instance from running.
Top
See Also

Reference

Extensions Class


Extensions.StopInstance Method (Manager, String)

ExtensionsStopInstance Method (Manager, String)

Stops the specified SQL Server Express LocalDB instance from running.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void StopInstance(
    this Manager manager,
    string instanceName
)
<ExtensionAttribute>
Public Shared Sub StopInstance (
    manager As Manager,
    instanceName As String
)
public:
[ExtensionAttribute]
static void StopInstance(
    Manager^ manager,
    String^ instanceName
)
[<ExtensionAttribute>]
static member StopInstance :
        manager : Manager *
        instanceName : string -> unit

Parameters

manager
Type: usis.Data.LocalDbManager
The LocalDB manager object.
instanceName
Type: SystemString
The name of the LocalDB instance to stop.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Manager. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentNullException | manager is a null reference.
Remarks
This function will return immediately without waiting for the LocalDB instance to stop.
See Also

Reference

Extensions Class
StopInstance Overload


Extensions.StopInstance Method (Manager, String, Int32)

ExtensionsStopInstance Method (Manager, String, Int32)

Stops the specified SQL Server Express LocalDB instance from running.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void StopInstance(
    this Manager manager,
    string instanceName,
    int timeout
)
<ExtensionAttribute>
Public Shared Sub StopInstance (
    manager As Manager,
    instanceName As String,
    timeout As Integer
)
public:
[ExtensionAttribute]
static void StopInstance(
    Manager^ manager,
    String^ instanceName,
    int timeout
)
[<ExtensionAttribute>]
static member StopInstance :
        manager : Manager *
        instanceName : string *
        timeout : int -> unit

Parameters

manager
Type: usis.Data.LocalDbManager
The LocalDB manager object.
instanceName
Type: SystemString
The name of the LocalDB instance to stop.
timeout
Type: SystemInt32
The time in seconds to wait for this operation to complete. If this value is 0, this function will return immediately without waiting for the LocalDB instance to stop.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Manager. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentNullException | manager is a null reference.
See Also

Reference

Extensions Class
StopInstance Overload


InstanceInfo Class

Provides information about a SQL Server Express LocalDB instance.
Inheritance Hierarchy
SystemObject
usis.Data.LocalDbInstanceInfo

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class InstanceInfo
Public Class InstanceInfo
public ref class InstanceInfo
type InstanceInfo =  class end

The InstanceInfo type exposes the following members.

Properties
 | Name | Description
Public property | ConfigurationCorrupted | Gets a value indicating whether the instance configuration registry is corrupted.
Public property | Connection | Gets the name of the TDS named pipe to connect to the instance.
Public property | Exists | Gets a value indicating whether the instance files exist on disk.
Public property | IsAutomatic | Gets a value indicating whether this instance is automatic.
Public property | IsRunning | Gets a value indicating whether this instance is running.
Public property | IsShared | Gets a value indicating whether this instance is shared.
Public property | LastStart | Gets the date and time when the instance was started for the last time.
Public property | Name | Gets the instance name.
Public property | Owner | Gets the SID of the instance owner.
Public property | SharedInstanceName | Gets the shared name for the instance (if the instance is shared).
Public property | Version | Gets the LocalDB version for the instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

usis.Data.LocalDb Namespace

Copyright © 2018 usis GmbH

Send comments on this topic to support@usis-software.com


InstanceInfo Properties

The InstanceInfo type exposes the following members.

Properties
 | Name | Description
Public property | ConfigurationCorrupted | Gets a value indicating whether the instance configuration registry is corrupted.
Public property | Connection | Gets the name of the TDS named pipe to connect to the instance.
Public property | Exists | Gets a value indicating whether the instance files exist on disk.
Public property | IsAutomatic | Gets a value indicating whether this instance is automatic.
Public property | IsRunning | Gets a value indicating whether this instance is running.
Public property | IsShared | Gets a value indicating whether this instance is shared.
Public property | LastStart | Gets the date and time when the instance was started for the last time.
Public property | Name | Gets the instance name.
Public property | Owner | Gets the SID of the instance owner.
Public property | SharedInstanceName | Gets the shared name for the instance (if the instance is shared).
Public property | Version | Gets the LocalDB version for the instance.
Top
See Also

Reference

InstanceInfo Class


InstanceInfo.ConfigurationCorrupted Property

InstanceInfoConfigurationCorrupted Property

Gets a value indicating whether the instance configuration registry is corrupted.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ConfigurationCorrupted { get; }
Public ReadOnly Property ConfigurationCorrupted As Boolean
    Get
public:
property bool ConfigurationCorrupted {
    bool get ();
}
member ConfigurationCorrupted : bool with get

Property Value

Type: Boolean
true if the instance configuration registry is corrupted; otherwise, false.
See Also

Reference

InstanceInfo Class


InstanceInfo.Connection Property

InstanceInfoConnection Property

Gets the name of the TDS named pipe to connect to the instance.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Connection { get; }
Public ReadOnly Property Connection As String
    Get
public:
property String^ Connection {
    String^ get ();
}
member Connection : string with get

Property Value

Type: String
The name of the TDS named pipe to connect to the instance.
See Also

Reference

InstanceInfo Class


InstanceInfo.Exists Property

InstanceInfoExists Property

Gets a value indicating whether the instance files exist on disk.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Exists { get; }
Public ReadOnly Property Exists As Boolean
    Get
public:
property bool Exists {
    bool get ();
}
member Exists : bool with get

Property Value

Type: Boolean
true if the instance files exist on disk; otherwise, false.
See Also

Reference

InstanceInfo Class


InstanceInfo.IsAutomatic Property

InstanceInfoIsAutomatic Property

Gets a value indicating whether this instance is automatic.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAutomatic { get; }
Public ReadOnly Property IsAutomatic As Boolean
    Get
public:
property bool IsAutomatic {
    bool get ();
}
member IsAutomatic : bool with get

Property Value

Type: Boolean
true if this instance is automatic; otherwise, false.
See Also

Reference

InstanceInfo Class


InstanceInfo.IsRunning Property

InstanceInfoIsRunning Property

Gets a value indicating whether this instance is running.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsRunning { get; }
Public ReadOnly Property IsRunning As Boolean
    Get
public:
property bool IsRunning {
    bool get ();
}
member IsRunning : bool with get

Property Value

Type: Boolean
true if this instance is running; otherwise, false.
See Also

Reference

InstanceInfo Class


InstanceInfo.IsShared Property

InstanceInfoIsShared Property

Gets a value indicating whether this instance is shared.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsShared { get; }
Public ReadOnly Property IsShared As Boolean
    Get
public:
property bool IsShared {
    bool get ();
}
member IsShared : bool with get

Property Value

Type: Boolean
true if this instance is shared; otherwise, false.
See Also

Reference

InstanceInfo Class


InstanceInfo.LastStart Property

InstanceInfoLastStart Property

Gets the date and time when the instance was started for the last time.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime LastStart { get; }
Public ReadOnly Property LastStart As DateTime
    Get
public:
property DateTime LastStart {
    DateTime get ();
}
member LastStart : DateTime with get

Property Value

Type: DateTime
The date and time when the instance was started for the last time.
See Also

Reference

InstanceInfo Class


InstanceInfo.Name Property

InstanceInfoName Property

Gets the instance name.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
The instance name.
See Also

Reference

InstanceInfo Class


InstanceInfo.Owner Property

InstanceInfoOwner Property

Gets the SID of the instance owner.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Owner { get; }
Public ReadOnly Property Owner As String
    Get
public:
property String^ Owner {
    String^ get ();
}
member Owner : string with get

Property Value

Type: String
The SID of the instance owner.
See Also

Reference

InstanceInfo Class


InstanceInfo.SharedInstanceName Property

InstanceInfoSharedInstanceName Property

Gets the shared name for the instance (if the instance is shared).

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SharedInstanceName { get; }
Public ReadOnly Property SharedInstanceName As String
    Get
public:
property String^ SharedInstanceName {
    String^ get ();
}
member SharedInstanceName : string with get

Property Value

Type: String
The shared name for the instance or null if the instance is not shared.
See Also

Reference

InstanceInfo Class


InstanceInfo.Version Property

InstanceInfoVersion Property

Gets the LocalDB version for the instance.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Version Version { get; }
Public ReadOnly Property Version As Version
    Get
public:
property Version^ Version {
    Version^ get ();
}
member Version : Version with get

Property Value

Type: Version
The LocalDB version for the instance.
See Also

Reference

InstanceInfo Class


InstanceInfo Methods

The InstanceInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

InstanceInfo Class


InstanceInfo.ToString Method

InstanceInfoToString Method

Returns a String that represents this instance.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A String that represents this instance.
See Also

Reference

InstanceInfo Class


LocalDbException Class

Throws an exception for a SQL Server Express LocalDB error.
Inheritance Hierarchy
SystemObject
SystemException
SystemSystemException
System.Runtime.InteropServicesExternalException
System.ComponentModelWin32Exception
usis.Data.LocalDbLocalDbException

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class LocalDbException : Win32Exception
<SerializableAttribute>
Public Class LocalDbException
    Inherits Win32Exception
[SerializableAttribute]
public ref class LocalDbException : public Win32Exception
[<SerializableAttribute>]
type LocalDbException =
    class
        inherit Win32Exception
    end

The LocalDbException type exposes the following members.

Constructors
 | Name | Description
Public method | LocalDbException | Initializes a new instance of the LocalDbException class.
Public method | LocalDbException(String) | Initializes a new instance of the LocalDbException class.
Protected method | LocalDbException(SerializationInfo, StreamingContext) | Initializes a new instance of the LocalDbException class.
Public method | LocalDbException(String, Exception) | Initializes a new instance of the LocalDbException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets the HRESULT of the error. (Inherited from ExternalException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | NativeErrorCode | Gets the Win32 error code associated with this exception. (Inherited from Win32Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo object with the file name and line number at which this Win32Exception occurred. (Inherited from Win32Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that contains the HRESULT of the error. (Inherited from ExternalException.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

usis.Data.LocalDb Namespace
System.ComponentModelWin32Exception


LocalDbException Constructor

Overload List
 | Name | Description
Public method | LocalDbException | Initializes a new instance of the LocalDbException class.
Public method | LocalDbException(String) | Initializes a new instance of the LocalDbException class.
Protected method | LocalDbException(SerializationInfo, StreamingContext) | Initializes a new instance of the LocalDbException class.
Public method | LocalDbException(String, Exception) | Initializes a new instance of the LocalDbException class.
Top
See Also

Reference

LocalDbException Class


LocalDbException Constructor

Initializes a new instance of the LocalDbException class.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LocalDbException()
Public Sub New
public:
LocalDbException()
new : unit -> LocalDbException
See Also

Reference

LocalDbException Class
LocalDbException Overload


LocalDbException Constructor (String)

Initializes a new instance of the LocalDbException class.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LocalDbException(
    string message
)
Public Sub New (
    message As String
)
public:
LocalDbException(
    String^ message
)
new :
        message : string -> LocalDbException

Parameters

message
Type: SystemString
A detailed description of the error.
See Also

Reference

LocalDbException Class
LocalDbException Overload


LocalDbException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the LocalDbException class.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected LocalDbException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
LocalDbException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> LocalDbException

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo associated with this exception.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext that represents the context of this exception.
See Also

Reference

LocalDbException Class
LocalDbException Overload


LocalDbException Constructor (String, Exception)

Initializes a new instance of the LocalDbException class.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LocalDbException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)
public:
LocalDbException(
    String^ message,
    Exception^ innerException
)
new :
        message : string *
        innerException : Exception -> LocalDbException

Parameters

message
Type: SystemString
A detailed description of the error.
innerException
Type: SystemException
A reference to the inner exception that is the cause of this exception.
See Also

Reference

LocalDbException Class
LocalDbException Overload


LocalDbException Properties

The LocalDbException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Gets the HRESULT of the error. (Inherited from ExternalException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | NativeErrorCode | Gets the Win32 error code associated with this exception. (Inherited from Win32Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

LocalDbException Class


LocalDbException Methods

The LocalDbException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo object with the file name and line number at which this Win32Exception occurred. (Inherited from Win32Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that contains the HRESULT of the error. (Inherited from ExternalException.)
Top
See Also

Reference

LocalDbException Class


LocalDbException Events

The LocalDbException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

LocalDbException Class


Manager Class

Provides methods to manage LocalDB instances.
Inheritance Hierarchy
SystemObject
usis.Data.LocalDbManager

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class Manager : IDisposable
Public NotInheritable Class Manager
    Implements IDisposable
public ref class Manager sealed : IDisposable
[<SealedAttribute>]
type Manager =
    class
        interface IDisposable
    end

The Manager type exposes the following members.

Methods
 | Name | Description
 | Create | Creates a new instance of the Manager class.
Public method | CreateInstance | Creates a new SQL Server Express LocalDB instance.
Public method | DeleteInstance | Removes the specified SQL Server Express LocalDB instance.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInstanceInfo | Gets information for the specified SQL Server Express LocalDB instance, such as whether it exists, the LocalDB version it uses, whether it is running, and so on.
Public method | GetInstances | Gets the names of both named and default LocalDB instances on the user’s workstation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersionInfo | Gets information for the specified SQL Server Express LocalDB version, such as whether it exists and the full LocalDB version number (including build and release numbers).
Public method | GetVersions | Returns all SQL Server Express LocalDB versions available on the computer.
 | IsInstalled | Determines whether SQL Server Express LocalDB is installed on the computer.
Public method | ShareInstance | Shares the specified SQL Server Express LocalDB instance with other users of the computer, using the specified shared name.
Public method | StartInstance | Starts the specified SQL Server Express LocalDB instance.
Public method | StartTracing | Enables tracing of API calls for all the SQL Server Express LocalDB instances owned by the current Windows user.
Public method | StopInstance | Stops the specified SQL Server Express LocalDB instance from running.
Public method | StopTracing | Disables tracing of API calls for all the SQL Server Express LocalDB instances owned by the current Windows user.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnshareInstance | Stops the sharing of the specified SQL Server Express LocalDB instance.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateInstance | Creates a new SQL Server Express LocalDB instance with the highest istalled version. (Defined by Extensions.)
Public Extension Method | EnumerateInstances | Gets the informations about both named and default LocalDB instances on the user’s workstation. (Defined by Extensions.)
Public Extension Method | EnumerateVersions | Returns all SQL Server Express LocalDB versions available on the computer. (Defined by Extensions.)
Public Extension Method | StopInstance(String) | Overloaded. Stops the specified SQL Server Express LocalDB instance from running. (Defined by Extensions.)
Public Extension Method | StopInstance(String, Int32) | Overloaded. Stops the specified SQL Server Express LocalDB instance from running. (Defined by Extensions.)
Top
See Also

Reference

usis.Data.LocalDb Namespace
SystemIDisposable


Manager Methods

The Manager type exposes the following members.

Methods
 | Name | Description
 | Create | Creates a new instance of the Manager class.
Public method | CreateInstance | Creates a new SQL Server Express LocalDB instance.
Public method | DeleteInstance | Removes the specified SQL Server Express LocalDB instance.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInstanceInfo | Gets information for the specified SQL Server Express LocalDB instance, such as whether it exists, the LocalDB version it uses, whether it is running, and so on.
Public method | GetInstances | Gets the names of both named and default LocalDB instances on the user’s workstation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVersionInfo | Gets information for the specified SQL Server Express LocalDB version, such as whether it exists and the full LocalDB version number (including build and release numbers).
Public method | GetVersions | Returns all SQL Server Express LocalDB versions available on the computer.
 | IsInstalled | Determines whether SQL Server Express LocalDB is installed on the computer.
Public method | ShareInstance | Shares the specified SQL Server Express LocalDB instance with other users of the computer, using the specified shared name.
Public method | StartInstance | Starts the specified SQL Server Express LocalDB instance.
Public method | StartTracing | Enables tracing of API calls for all the SQL Server Express LocalDB instances owned by the current Windows user.
Public method | StopInstance | Stops the specified SQL Server Express LocalDB instance from running.
Public method | StopTracing | Disables tracing of API calls for all the SQL Server Express LocalDB instances owned by the current Windows user.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnshareInstance | Stops the sharing of the specified SQL Server Express LocalDB instance.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateInstance | Creates a new SQL Server Express LocalDB instance with the highest istalled version. (Defined by Extensions.)
Public Extension Method | EnumerateInstances | Gets the informations about both named and default LocalDB instances on the user’s workstation. (Defined by Extensions.)
Public Extension Method | EnumerateVersions | Returns all SQL Server Express LocalDB versions available on the computer. (Defined by Extensions.)
Public Extension Method | StopInstance(String) | Overloaded. Stops the specified SQL Server Express LocalDB instance from running. (Defined by Extensions.)
Public Extension Method | StopInstance(String, Int32) | Overloaded. Stops the specified SQL Server Express LocalDB instance from running. (Defined by Extensions.)
Top
See Also

Reference

Manager Class


Manager.Create Method

ManagerCreate Method

Creates a new instance of the Manager class.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Manager Create()
Public Shared Function Create As Manager
public:
static Manager^ Create()
static member Create : unit -> Manager

Return Value

Type: Manager
A newly created instance of the Manager class.
See Also

Reference

Manager Class


Manager.CreateInstance Method

ManagerCreateInstance Method

Creates a new SQL Server Express LocalDB instance.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void CreateInstance(
    string version,
    string instanceName
)
Public Sub CreateInstance (
    version As String,
    instanceName As String
)
public:
void CreateInstance(
    String^ version,
    String^ instanceName
)
member CreateInstance :
        version : string *
        instanceName : string -> unit

Parameters

version
Type: SystemString
The LocalDB version, for example 11.0 or 11.0.1094.2.
instanceName
Type: SystemString
The name for the LocalDB instance to create.
See Also

Reference

Manager Class


Manager.DeleteInstance Method

ManagerDeleteInstance Method

Removes the specified SQL Server Express LocalDB instance.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void DeleteInstance(
    string instanceName
)
Public Sub DeleteInstance (
    instanceName As String
)
public:
void DeleteInstance(
    String^ instanceName
)
member DeleteInstance :
        instanceName : string -> unit

Parameters

instanceName
Type: SystemString
The name of the LocalDB instance to remove.
See Also

Reference

Manager Class


Manager.Dispose Method

ManagerDispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Manager Class


Manager.GetInstanceInfo Method

ManagerGetInstanceInfo Method

Gets information for the specified SQL Server Express LocalDB instance, such as whether it exists, the LocalDB version it uses, whether it is running, and so on.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public InstanceInfo GetInstanceInfo(
    string instanceName
)
Public Function GetInstanceInfo (
    instanceName As String
) As InstanceInfo
public:
InstanceInfo^ GetInstanceInfo(
    String^ instanceName
)
member GetInstanceInfo :
        instanceName : string -> InstanceInfo

Parameters

instanceName
Type: SystemString
Name of the instance.

Return Value

Type: InstanceInfo
The information about the specified LocalDB instance.
See Also

Reference

Manager Class


Manager.GetInstances Method

ManagerGetInstances Method

Gets the names of both named and default LocalDB instances on the user’s workstation.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] GetInstances()
Public Function GetInstances As String()
public:
array<String^>^ GetInstances()
member GetInstances : unit -> string[]

Return Value

Type: String
An array that contains the names of both named and default LocalDB instances on the user’s workstation.
See Also

Reference

Manager Class


Manager.GetVersionInfo Method

ManagerGetVersionInfo Method

Gets information for the specified SQL Server Express LocalDB version, such as whether it exists and the full LocalDB version number (including build and release numbers).

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VersionInfo GetVersionInfo(
    string version
)
Public Function GetVersionInfo (
    version As String
) As VersionInfo
public:
VersionInfo^ GetVersionInfo(
    String^ version
)
member GetVersionInfo :
        version : string -> VersionInfo

Parameters

version
Type: SystemString
The LocalDB version name.

Return Value

Type: VersionInfo
The information about the specified LocalDB version.
See Also

Reference

Manager Class


Manager.GetVersions Method

ManagerGetVersions Method

Returns all SQL Server Express LocalDB versions available on the computer.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] GetVersions()
Public Function GetVersions As String()
public:
array<String^>^ GetVersions()
member GetVersions : unit -> string[]

Return Value

Type: String
An array that contains the names of the LocalDB versions that are available on the user’s workstation.
See Also

Reference

Manager Class


Manager.IsInstalled Method

ManagerIsInstalled Method

Determines whether SQL Server Express LocalDB is installed on the computer.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsInstalled()
Public Shared Function IsInstalled As Boolean
public:
static bool IsInstalled()
static member IsInstalled : unit -> bool

Return Value

Type: Boolean
true if SQL Server Express LocalDB is installed on the computer; otherwise, false.
See Also

Reference

Manager Class


Manager.ShareInstance Method

ManagerShareInstance Method

Shares the specified SQL Server Express LocalDB instance with other users of the computer, using the specified shared name.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ShareInstance(
    string owner,
    string instancePrivateName,
    string instanceSharedName
)
Public Sub ShareInstance (
    owner As String,
    instancePrivateName As String,
    instanceSharedName As String
)
public:
void ShareInstance(
    String^ owner,
    String^ instancePrivateName,
    String^ instanceSharedName
)
member ShareInstance :
        owner : string *
        instancePrivateName : string *
        instanceSharedName : string -> unit

Parameters

owner
Type: SystemString
The SID of the instance owner.
instancePrivateName
Type: SystemString
The private name for the LocalDB instance to share.
instanceSharedName
Type: SystemString
The shared name for the LocalDB instance to share.
See Also

Reference

Manager Class


Manager.StartInstance Method

ManagerStartInstance Method

Starts the specified SQL Server Express LocalDB instance.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string StartInstance(
    string instanceName
)
Public Function StartInstance (
    instanceName As String
) As String
public:
String^ StartInstance(
    String^ instanceName
)
member StartInstance :
        instanceName : string -> string

Parameters

instanceName
Type: SystemString
The name of the LocalDB instance to start.

Return Value

Type: String
The name of the TDS named pipe to connect to the instance.
See Also

Reference

Manager Class


Manager.StartTracing Method

ManagerStartTracing Method

Enables tracing of API calls for all the SQL Server Express LocalDB instances owned by the current Windows user.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void StartTracing()
Public Sub StartTracing
public:
void StartTracing()
member StartTracing : unit -> unit
See Also

Reference

Manager Class


Manager.StopInstance Method

ManagerStopInstance Method

Stops the specified SQL Server Express LocalDB instance from running.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void StopInstance(
    string instanceName,
    StopInstanceOptions options,
    TimeSpan timeout
)
Public Sub StopInstance (
    instanceName As String,
    options As StopInstanceOptions,
    timeout As TimeSpan
)
public:
void StopInstance(
    String^ instanceName,
    StopInstanceOptions options,
    TimeSpan timeout
)
member StopInstance :
        instanceName : string *
        options : StopInstanceOptions *
        timeout : TimeSpan -> unit

Parameters

instanceName
Type: SystemString
The name of the LocalDB instance to stop.
options
Type: usis.Data.LocalDbStopInstanceOptions
One or a combination of the option values specifying the way to stop the instance.
timeout
Type: SystemTimeSpan
The time to wait for this operation to complete. If this value is 0, this function will return immediately without waiting for the LocalDB instance to stop.
See Also

Reference

Manager Class


Manager.StopTracing Method

ManagerStopTracing Method

Disables tracing of API calls for all the SQL Server Express LocalDB instances owned by the current Windows user.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void StopTracing()
Public Sub StopTracing
public:
void StopTracing()
member StopTracing : unit -> unit
See Also

Reference

Manager Class


Manager.UnshareInstance Method

ManagerUnshareInstance Method

Stops the sharing of the specified SQL Server Express LocalDB instance.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UnshareInstance(
    string instanceName
)
Public Sub UnshareInstance (
    instanceName As String
)
public:
void UnshareInstance(
    String^ instanceName
)
member UnshareInstance :
        instanceName : string -> unit

Parameters

instanceName
Type: SystemString
The shared name for the LocalDB instance to unshare.
See Also

Reference

Manager Class


StopInstanceOptions Enumeration

Describes to options that spectify the way to stop an instance.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum StopInstanceOptions
<FlagsAttribute>
Public Enumeration StopInstanceOptions
[FlagsAttribute]
public enum class StopInstanceOptions
[<FlagsAttribute>]
type StopInstanceOptions
Members
Member name | Value | Description
None | 0 | Shut down by using the SHUTDOWN Transact-SQL command.
ShutdownKillProcess | 1 | Shut down immediately using the kill process operating system command.
ShutdownWithNoWait | 2 | Shut down using the WITH NOWAIT option Transact-SQL command.
See Also

Reference

usis.Data.LocalDb Namespace

Copyright © 2018 usis GmbH

Send comments on this topic to support@usis-software.com


VersionInfo Class

Provides information about a SQL Server Express LocalDB version.
Inheritance Hierarchy
SystemObject
usis.Data.LocalDbVersionInfo

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VersionInfo
Public Class VersionInfo
public ref class VersionInfo
type VersionInfo =  class end

The VersionInfo type exposes the following members.

Properties
 | Name | Description
Public property | Exists | Gets a value indicating whether the instance files exist on disk.
Public property | Name | Gets the LocalDB version name.
Public property | Version | Gets the LocalDB version for the instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

usis.Data.LocalDb Namespace

Copyright © 2018 usis GmbH

Send comments on this topic to support@usis-software.com


VersionInfo Properties

The VersionInfo type exposes the following members.

Properties
 | Name | Description
Public property | Exists | Gets a value indicating whether the instance files exist on disk.
Public property | Name | Gets the LocalDB version name.
Public property | Version | Gets the LocalDB version for the instance.
Top
See Also

Reference

VersionInfo Class


VersionInfo.Exists Property

VersionInfoExists Property

Gets a value indicating whether the instance files exist on disk.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Exists { get; }
Public ReadOnly Property Exists As Boolean
    Get
public:
property bool Exists {
    bool get ();
}
member Exists : bool with get

Property Value

Type: Boolean
true if the instance files exist on disk; otherwise, false.
See Also

Reference

VersionInfo Class


VersionInfo.Name Property

VersionInfoName Property

Gets the LocalDB version name.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
The LocalDB version name.
See Also

Reference

VersionInfo Class


VersionInfo.Version Property

VersionInfoVersion Property

Gets the LocalDB version for the instance.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Version Version { get; }
Public ReadOnly Property Version As Version
    Get
public:
property Version^ Version {
    Version^ get ();
}
member Version : Version with get

Property Value

Type: Version
The LocalDB version for the instance.
See Also

Reference

VersionInfo Class


VersionInfo Methods

The VersionInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

VersionInfo Class


VersionInfo.ToString Method

VersionInfoToString Method

Returns a String that represents this instance.

Namespace: usis.Data.LocalDb
Assembly: usis.Data.LocalDb (in usis.Data.LocalDb.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A String that represents this instance.
See Also

Reference

VersionInfo Class